Call Quality Issues with Upstream Carrier

Incident Report for Level365

Resolved

This incident has been resolved.
Posted Apr 18, 2022 - 07:57 EDT

Monitoring

Our upstream provider has addressed this issue and we are no longer seeing packet loss.
Posted Apr 15, 2022 - 16:46 EDT

Update

We are continuing to work with the carrier to identify the source of the packet loss originating from their network.
Posted Apr 15, 2022 - 08:10 EDT

Update

We are continuing to investigate this issue.
Posted Apr 14, 2022 - 14:38 EDT

Update

We are continuing to work with the carrier to identify the source of the packet loss originating from their network.
Posted Apr 14, 2022 - 07:55 EDT

Update

We are continuing to investigate this issue.
Posted Apr 13, 2022 - 20:22 EDT

Update

We are continuing to work with the carrier to identify the source of the packet loss originating from their network.
Posted Apr 13, 2022 - 15:54 EDT

Update

We continue to investigate with the carrier on this issue
Posted Apr 13, 2022 - 12:00 EDT

Investigating

We are currently investigating call quality issues with one of our upstream providers which may be impacting some users on inbound calls.
Posted Apr 13, 2022 - 10:58 EDT
This incident affected: Voice Carriers (Inteliquent).