Intermittent Toll Free Call Issues
Incident Report for Level365
Resolved
Engineers have resolved the issue that was impacting outbound calls.
Posted Mar 16, 2020 - 16:12 EDT
Investigating
We are currently experiencing an intermittent service issue via one of our carriers that affects call termination, causing some calls to experience call setup issues or dropped calls. Our carrier is investigating the underlying cause and we will provide an update as soon as possible
Posted Mar 16, 2020 - 15:42 EDT
This incident affected: Voice Carriers (Thinq).