Spectrum Internet in Owensboro exhibiting issues.
Incident Report for Level365
Resolved
Spectrum is reporting that this issue is resolved. If you are still having issues, please contact Spectrum Support.
Posted Sep 07, 2021 - 17:27 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 07, 2021 - 16:47 EDT
Investigating
Reports are coming in from the Owensboro area that Spectrum ISP users are reporting their connections are going up and down.
Posted Sep 07, 2021 - 13:36 EDT
This incident affected: Other.