Web Access Interruption
Incident Report for Level365
Resolved
Portal access has been restored.
Posted Nov 17, 2020 - 12:44 EST
Investigating
We are currently investigating a disruption for some customers with the web portal.
Posted Nov 17, 2020 - 12:37 EST
This incident affected: UCaaS (Portal).