Some faxes not completing

Incident Report for Level365

Resolved

This incident has been resolved. No further issues have been reported since services were restored.

We sincerely apologize for this interruption and if you have any additional troubles, please contact our support team at support.level365.com.
Posted 10 months ago. Aug 01, 2024 - 10:55 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Jul 30, 2024 - 19:48 EDT

Investigating

We are currently investigating reports of some faxes not completing.
Posted 10 months ago. Jul 30, 2024 - 15:32 EDT
This incident affected: UCaaS (Fax Services).