Inbound Call Completion Issues
Incident Report for Level365
Resolved
Problem appears to be resolved. Closing this incident.
Posted 6 months ago. Mar 13, 2019 - 11:57 EDT
Monitoring
Calls appear to be flowing properly. We are continuing to monitor at this time.
Posted 6 months ago. Mar 13, 2019 - 10:11 EDT
Investigating
We are currently investigating an issue with some inbound calls on one of our carriers. We are working with the carrier to identify the issue and mitigate as quickly as possible.
Posted 6 months ago. Mar 13, 2019 - 09:53 EDT
This incident affected: Voice Carriers (Bandwidth).