Investigating issues with Level365 Web App Login

Incident Report for Level365

Update

We are continuing to investigate reports of issues with the Web App related to logging in and components not loading properly once logged in. Further updates will be provided as more information becomes available.
Posted Sep 10, 2026 - 10:57 EDT

Investigating

We are currently investigating reports of some users being unable to log in to the Level365 Web App (app.level365.com). Our team is actively working to identify the cause, and further updates will be provided as more information becomes available.
Posted Sep 10, 2026 - 09:44 EDT
This incident affects: Web App / Portal.