Video Collaboration Issues
Incident Report for Level365
Resolved
Service has been stable. We are considering this issue resolved at this time.
Posted 24 days ago. Aug 27, 2019 - 12:59 EDT
Monitoring
Issues have stabilized and we are monitoring to ensure ongoing stability.
Posted 24 days ago. Aug 27, 2019 - 10:07 EDT
Investigating
We are currently investigating an issue with video collaboration being intermittently inaccessible.
Posted 25 days ago. Aug 26, 2019 - 11:18 EDT
This incident affected: UCaaS (Video Collaboration).