Global Internet Disruption
Incident Report for Level365
Resolved
This incident is now considered resolved. Postmortem will be provided soon.
Posted Aug 30, 2020 - 17:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2020 - 11:41 EDT
Update
Core issue appears to be resolved at this time. We are continuing to monitor.

https://mobile.twitter.com/centurylink/status/1300089110858797063
Posted Aug 30, 2020 - 11:40 EDT
Update
CenturyLink is confirming they have began rolling out changes to address the disruption. We continue to monitor to confirm this resolves connectivity issues to us.
Posted Aug 30, 2020 - 11:21 EDT
Update
We are continuing to monitor the situation. CenturyLink continues to have issues that are impacting access to our platform in some situations.
Posted Aug 30, 2020 - 10:32 EDT
Update
We have temporarily removed CenturyLink from our global routing tables to ensure no transit traffic comes directly from them. Some clients may still have issues, but removing CenturyLink has restored access for the majority of impacted clients.
Posted Aug 30, 2020 - 09:30 EDT
Identified
We are currently monitoring a global internet disruption that is causing issues with phone registration and call completion for some customers. We believe this issue resides with Level 3/CenturyLink and is impacting large scale service providers such as Comcast. We are continuing to investigate any action we can take to mitigate this issue.
Posted Aug 30, 2020 - 08:07 EDT
This incident affected: Data Carriers (Level 3).