Cloudflare Global Outage Advisory

Incident Report for Level365

Resolved

Cloudflare has reported that the earlier global service outage has been fully resolved. Any intermittent issues affecting external services relying on Cloudflare should now be returning to normal operation.

Level365 core services were not impacted by this incident. If you notice anything unexpected or need assistance, please reach out to our support team at support.level365.com.

For additional details, you may follow Cloudflare’s incident report here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:03 EST

Identified

Cloudflare is currently experiencing a global service outage, which may cause intermittent or unexpected behavior with certain external services. This is a widespread incident affecting a number of services, including (for example) Microsoft 365 and other major platforms that rely on Cloudflare’s network.

Level365's core services are not impacted, but some clients may experience side effects related to the broader Cloudflare disruption. If you experience any issues, please contact our support team at support.level365.com.

Cloudflare has identified the problem and is implementing a fix. We are actively monitoring the situation and expect service to be restored shortly. You may also follow Cloudflare’s incident updates here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 09:22 EST
This incident affected: Service Providers (Data Carriers).