Outbound Dialing Issues
Incident Report for Level365
Resolved
Carrier has confirmed that service has been restored.
Posted Apr 16, 2021 - 13:09 EDT
Update
We continue to monitor, but have seen zero examples of PDD since overnight.
Posted Apr 16, 2021 - 09:30 EDT
Monitoring
The downstream carrier has been working with their downstream carrier and the issue appears to be better. We are continuing to monitor at this time.
Posted Apr 16, 2021 - 08:00 EDT
Update
We have received word from our primary carrier that one of the offending downstream carriers causing the dialing delays experienced earlier has made some routing changes. Current traffic appears to have improved but we are continuing to monitor the situation.
Posted Apr 15, 2021 - 22:15 EDT
Update
Please be aware, outbound calls are not failing. If you experience this issue on a call, wait an additional 15-20s for the call to connect. Calls will complete if you allow them additional time to start ringing.
Posted Apr 15, 2021 - 19:57 EDT
Investigating
We are investigating an issue with a downstream carrier regrading Post Dial Delay. You may experience dead air on outbound calls. We are actively engaging our carriers to get this resolved.
Posted Apr 15, 2021 - 19:24 EDT
This incident affected: Voice Carriers (Bandwidth).