Addressing Post Maintenance Issues
Incident Report for Level365
Resolved
We have not received any reports of additional issues and consider this resolved.
Posted Jun 07, 2024 - 08:02 EDT
Monitoring
All phone numbers should now be visible through the Level365 Web App. We will continue to monitor this issue.
Posted Jun 06, 2024 - 15:29 EDT
Update
Desk phone updates and directory lookup issues have been fixed. We are continuing to work on the issues related to DIDs not populating in the Phone Numbers Inventory through the Level365 Web App.
Posted Jun 05, 2024 - 20:45 EDT
Update
We are continuing to work on getting impacted services fixed.
Posted Jun 05, 2024 - 13:36 EDT
Identified
We have identified the sources causing the reported issues and are working towards getting fixes in place.
Posted Jun 05, 2024 - 10:45 EDT
Investigating
We are currently investigating reports of some phone numbers not displaying in the Level365 Web App as well as reports of desk phones not updating and/or populating the directory.

At this time we do not recommend factory resetting devices or making hardware changes.
Posted Jun 05, 2024 - 09:46 EDT
This incident affected: UCaaS (Provisioning, Web App / Portal).