Fax Issues
Incident Report for Level365
Resolved
Issue has been resolved, and all functionality restored.
Posted over 1 year ago. Jan 19, 2018 - 13:32 EST
Identified
The problem has been identified and Engineering is working on the solution.
Posted over 1 year ago. Jan 19, 2018 - 12:17 EST
Investigating
We are investigating an issue with our faxing solution. We are working with the vendor to identify and resolve the issue.
Posted over 1 year ago. Jan 19, 2018 - 11:50 EST