Investigating issues with Inbound Caller Name Displaying

Incident Report for Level365

Resolved

Inbound CallerID Name is now working properly. If you are still experiencing issues with this, please contact support.
Posted Mar 03, 2025 - 13:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2025 - 12:47 EST

Investigating

We are investigating issues with Inbound Caller Name Displaying and will provide updates here soon.
Posted Mar 03, 2025 - 10:30 EST