Call Recordings Not Showing in Call History

Incident Report for Level365

Postmortem

Complications occurred during the 5/21/24 maintenance update, which prevented the recording server from returning online. Personnel were dispatched to the data center to apply a fix. During this time the secondary recording server was still recording calls, they were just inaccessible via our Web App.

At approximately noon ET, our primary recording server connection was restored and recordings that occurred before our maintenance as well as new recordings were once again accessible. However, call recordings during the downtime were still inaccessible from our secondary recording server. The configuration of the secondary recording server was then updated, which restored all recordings, and will help prevent this type of incident in the future.

Posted Jun 03, 2024 - 11:19 EDT

Resolved

There have not been any new issues reported regarding call recordings since recording services were restored this afternoon. We consider this incident to be resolved. We are aware there are some recordings from this morning that are not showing up in Call History and we will continue to work towards restoring those call recordings.
Posted May 21, 2024 - 17:20 EDT

Monitoring

We have implemented a fix and call recordings are starting to populate in Call History. There may be some call recordings from this morning that do not populate and we are working to get those restored.
Posted May 21, 2024 - 12:14 EDT

Identified

We have identified the cause of the issue and are working towards a resolution as quickly as we can.
Posted May 21, 2024 - 09:33 EDT

Investigating

We are currently investigating reports of call recordings not showing up in Call History.
Posted May 21, 2024 - 08:52 EDT
This incident affected: UCaaS (Recording).