Calls Not Completing to Specific Numbers
Incident Report for Level365
Resolved
We have replaced some routing equipment that was causing intermittent routing issues from one of our secondary carriers. We will continue to monitor this change, but everything is stable at this time and we consider this issue to be resolved.

Please contact our support team at support.level365.com if you need any further assistance.
Posted May 07, 2024 - 09:04 EDT
Monitoring
Services have been restored for the affected numbers. We will continue to monitor the situation.
Posted May 03, 2024 - 13:39 EDT
Investigating
We are investigating new reports of calls failing. Updates to follow.
Posted May 03, 2024 - 12:49 EDT
Monitoring
We have identified the root cause and have applied a fix. Our testing indicates the issue should be resolved. We are continuing to monitor the issue and will provide additional updates as necessary.
Posted May 03, 2024 - 11:22 EDT
Investigating
We have received reports of calls not completing to certain numbers. We are investigating the issue and are working towards identifying the the root cause.
Posted May 03, 2024 - 10:29 EDT
This incident affected: UCaaS (Core Services).