Inbound and Outbound Impairment
Incident Report for Level365
Resolved
We are seeing outbound voice services fully restored at this time.
Posted over 1 year ago. Jan 10, 2018 - 11:23 EST
Monitoring
We are seeing outbound voice services stabilize at this time. We are continuing to monitor for full stability.
Posted over 1 year ago. Jan 10, 2018 - 10:52 EST
Investigating
We are investigating an intermittent impairment impacting Inbound and Outbound Voice services involving one of our carriers.
Posted over 1 year ago. Jan 10, 2018 - 10:35 EST