Inbound call issues September 28
Incident Report for Level365
Resolved
We are currently observing ongoing network stability. All call types are processing as expected at this time. We consider this incident resolved
Posted Sep 28, 2021 - 22:53 EDT
Identified
The upstream carrier is actively investigating an incident causing intermittent service disruption to inbound calls. We will continue to provide updates as they develop.
Posted Sep 28, 2021 - 14:53 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2021 - 10:14 EDT
This incident affected: UCaaS (Core Services) and Voice Carriers (Bandwidth).