Issue with inbound and outbound calls
Incident Report for Level365
Resolved
Carrier has resolved this issue.
Posted Jun 16, 2020 - 13:24 EDT
Identified
One of our upstream carriers is having issues with some inbound and outbound calls. They are actively working on the issue.
Posted Jun 15, 2020 - 18:08 EDT
This incident affected: Voice Carriers (Bandwidth).