May 14th - Issue with voicemail to email delivery
Incident Report for Level365
Resolved
Overnight maintenance was successful. Voicemail to email delivery is fully functional. If you are still having issues, please contact our support staff.
Posted over 1 year ago. May 14, 2018 - 09:15 EDT
Identified
Our engineers have identified an issue with the UCaaS platform that is preventing voicemails from being delivered to email. These voice messages can still be accessed through the phone itself and/or by logging into your account at myvoiceportal.com.

We will be performing emergency maintenance this evening to resolve the issue.

We apologize for the inconvenience.
Posted over 1 year ago. May 14, 2018 - 11:17 EDT
This incident affected: UCaaS (Core).