Incorrect Google Safe Browsing Warning
Incident Report for Level365
Resolved
Google has confirmed removal of the incorrect reports. This issue is considered resolved.
Posted Mar 11, 2021 - 20:15 EST
Update
Our initial investigation has confirmed that this is a false positive. We are working with Google to identify exactly what triggered on their side, why it triggered, and how we can avoid it in the future. In addition, the required review is underway with Google to get the false positives removed from their Safe Search database.

There is no risk posed by our web app or any of the pages contained within. This is strictly a matter of Google acting overly aggressive in an automated manner with no manual review involved.
Posted Mar 11, 2021 - 09:25 EST
Investigating
We are currently investigating a false positive Google Safe Browsing warning on several pages within our web application.
Posted Mar 11, 2021 - 08:34 EST
This incident affected: UCaaS (Portal).