Power issue in Corporate Offices
Incident Report for Level365
Resolved
Power has been restored and all technical support operations are back to normal.
Posted Aug 27, 2020 - 13:26 EDT
Identified
We are currently experiencing a power outage at our corporate offices. Technical support is operating in a limited capacity and response times may be higher than normal.
Posted Aug 27, 2020 - 11:27 EDT
This incident affected: Other.