Investigating issues with Fax Services
Incident Report for Level365
Resolved
We are continuing to monitor for any further issues.
Posted Apr 26, 2024 - 14:41 EDT
Monitoring
We have identified the issue impacting faxing services and have implemented a fix. Services have been restored and we will be monitoring all services to ensure everything is back to normal.
Please be aware some faxes may be delayed or require additional attempts as the system processes all queued messages.
Posted Apr 26, 2024 - 09:10 EDT
Investigating
We are investigating issues reported with faxing services and will provide updates here soon.
Posted Apr 26, 2024 - 08:50 EDT
This incident affected: UCaaS (Fax Services).