Issue with DC Data Center
Incident Report for Level365
Resolved
Connectivity has been re-established and all systems should be working as expected.
Posted Nov 13, 2021 - 08:29 EST
Investigating
We are currently investigating a connectivity issue with our DC data center.
Posted Nov 13, 2021 - 00:40 EST
This incident affected: UCaaS (Core).