Investigating issues with Fax Services
Incident Report for Level365
Resolved
We are continuing to monitor for any further issues.
Posted Mar 05, 2024 - 19:10 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 05, 2024 - 19:09 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 05, 2024 - 17:55 EST
Monitoring
We have identified the issue impacting faxing services and have implemented a fix. Services appear to be restored and we will be monitoring all services to ensure everything is back to normal.
Please be aware some faxes may be delayed or require additional attempts as the system processes all queued messages.
Posted Mar 05, 2024 - 17:14 EST
Investigating
We are investigating issues reported with faxing services and will provide updates here soon.
Posted Mar 05, 2024 - 15:34 EST
This incident affected: UCaaS (Fax Services).