Issue with inbound calls from AT&T in Owensboro KY area
Incident Report for Level365
Resolved
AT&T has resolved this issue.
Posted Aug 13, 2021 - 17:12 EDT
Investigating
We are currently investigating this issue.
Posted Aug 13, 2021 - 13:40 EDT
This incident affected: UCaaS (Core Services) and Voice Carriers (Inteliquent).