We are tracking an issue with call quality reports this morning

Incident Report for Level365

Resolved

This incident has been resolved.
Posted Sep 13, 2021 - 16:49 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 13, 2021 - 15:00 EDT

Monitoring

Engineering has identified the issue and has deployed a solution. We are continuing to monitor to confirm stability of services.
Posted Sep 13, 2021 - 14:59 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 13, 2021 - 14:53 EDT

Update

We are continuing to investigate this issue.
Posted Sep 13, 2021 - 13:00 EDT

Investigating

We are currently investigating this issue.
Posted Sep 13, 2021 - 09:27 EDT
This incident affected: UCaaS (Core Services).