Faxes Not Completing
Incident Report for Level365
Postmortem

A bug was identified in the latest software release which was creating inconsistent connections. A fix was applied to resolve this issue. All fax communication processed normally once the patch was in place. We apologize for any inconvenience this issue may have caused. We are also adding additional infrastructure for increased redundancy of the faxing services to help reduce future issues.

Posted Jun 04, 2024 - 09:57 EDT

Resolved
Faxing services are fully operational and all faxes in the backlog have been processed.
Posted May 29, 2024 - 19:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Please note, some faxes may be delayed or require additional attempts as the system processes queued faxes.
Posted May 29, 2024 - 17:41 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 29, 2024 - 15:11 EDT
Identified
We have identified an issue with the server not responding to fax requests. We are working on applying a fix and will provide more updates soon.
Posted May 29, 2024 - 12:37 EDT
Investigating
We are currently investigating faxes not completing. We will provide more updates soon.
Posted May 29, 2024 - 12:21 EDT
This incident affected: UCaaS (Fax Services).