Upstream Carrier Issues
Incident Report for Level365
Resolved
The upstream carrier has indicated that this issue has been resolved, and we have observed network stability with them. We now consider this incident resolved.
Posted Oct 01, 2021 - 15:31 EDT
Identified
One of our upstream carriers is having an outage. This will impact some inbound calls. Outbound should be unaffected. We are working to mitigate as much as possible while we wait for the carrier to resolve their issue.
Posted Sep 29, 2021 - 09:18 EDT
This incident affected: Voice Carriers (Bandwidth).