Distinctive Ring Issues
Incident Report for Level365
Resolved
This issue is now considered resolved. If you continue to have issues, please contact support @ https://support.level365.com
Posted 3 months ago. Jun 28, 2019 - 15:25 EDT
Monitoring
Fix has been implemented and we are monitoring to ensure the problem is resolved.
Posted 3 months ago. Jun 28, 2019 - 13:29 EDT
Identified
We have identified the issue and are confirming a fix for it at this time.
Posted 3 months ago. Jun 28, 2019 - 09:36 EDT
Investigating
We are currently investigating reports of issues with distinctive ring on some calls.
Posted 3 months ago. Jun 28, 2019 - 09:03 EDT