Issue with Billing Portal
Incident Report for Level365
Resolved
Problem has been resolved and billing portal fully functional.
Posted 10 months ago. Dec 03, 2018 - 12:52 EST
Identified
We are currently working on a connectivity issue with the billing portal.
Posted 10 months ago. Dec 03, 2018 - 11:06 EST
This incident affected: Support Services (Billing).