Investigating issues with Fax Services
Incident Report for Level365
Resolved
Faxing services are now fully operational, all faxes in the backlog have been processed.
Posted Jan 30, 2024 - 21:38 EST
Monitoring
A fix has been implemented and we are monitoring the results. Please note that some faxes may be delayed or require additional attempts as the system processes the queued messages.
Posted Jan 30, 2024 - 16:22 EST
Identified
The issue has been identified and a fix is being implemented. We will provide additional updates here as they become available.
Posted Jan 30, 2024 - 15:25 EST
Investigating
We are investigating issues reported with faxing services and will provide updates here soon.
Posted Jan 30, 2024 - 14:07 EST
This incident affected: UCaaS (Fax Services).