Local Market Impairment - Bloomington, IN
Incident Report for Level365
Resolved
Carrier has resolved the issue.
Posted 5 months ago. Apr 27, 2019 - 02:00 EDT
Identified
Our carrier has identified an equipment malfunction and is working to complete repairs.
Posted 5 months ago. Apr 26, 2019 - 13:28 EDT
Investigating
One of our carriers is experiencing an issue affecting Local Inbound calls to the Bloomington area. Inbound long-distance and Outbound calling are not impacted.
Posted 5 months ago. Apr 25, 2019 - 13:22 EDT
This incident affected: Voice Carriers (Bandwidth).