Issues with Email Delivery
Incident Report for Level365
Resolved
Update has resolved the issue and email is being delivered properly.
Posted Feb 14, 2020 - 14:15 EST
Update
The core problem has been traced to a particular function, which is blocking additional processing. As usage increases during the day, the queue gets to a point that it cannot maintain "real-time" delivery of these messages. As the usage decreases later in the day, the queue begins to catch up.

Engineering has released a fix for this issue, and it will be rolled out tonight during an emergency maintenance window.
Posted Feb 13, 2020 - 11:48 EST
Update
Email delivery has been stable. We are continuing to monitor for prompt delivery.
Posted Feb 12, 2020 - 09:03 EST
Monitoring
Engineering has indicated that they have found the issue and implemented a fix. We will continue to monitor the resolution.
Posted Feb 11, 2020 - 12:36 EST
Update
Problem appears to still be an issue. Engineering is continuing to troubleshoot the delay.
Posted Feb 11, 2020 - 08:53 EST
Update
The delay on sending emails appears to be resolved. We will continue to monitor the situation.
Posted Feb 10, 2020 - 08:49 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2020 - 17:00 EST
Update
Engineers have isolated the issue and are still working towards a resolution.
Posted Feb 07, 2020 - 16:37 EST
Update
It appears that there is a delay in delivering new emails. We are working to identify the cause of the delay.
Posted Feb 07, 2020 - 10:14 EST
Investigating
We are currently investigating reports of some email notifications not being delivered properly.
Posted Feb 07, 2020 - 09:57 EST
This incident affected: Other.