Fax Issues
Incident Report for Level365
Resolved
Service is stable. We are considering this issue resolved.
Posted over 1 year ago. May 08, 2018 - 12:32 EDT
Monitoring
Problem has been resolved. We are continuing to monitor the issue to confirm.
Posted over 1 year ago. May 08, 2018 - 09:47 EDT
Investigating
We are currently investigating a disruption with our fax services. This problem is affecting both inbound and outbound faxes.
Posted over 1 year ago. May 08, 2018 - 09:25 EDT
This incident affected: UCaaS (Fax Services).