Call quality issues October 19th 2020
Incident Report for Level365
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:23 EDT
Monitoring
Traffic patterns have stabilized and we are monitoring.
Posted Oct 19, 2020 - 13:48 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2020 - 13:37 EDT
Investigating
We are currently investigating this issue.
Posted Oct 19, 2020 - 13:13 EDT
This incident affected: UCaaS (Core Services).